Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 22, 2025 - 10:00 CAT
Scheduled
Scheduled maintenance to support continuous improvement and infrastructure upgrades. RfQ on App, API, and Website will be temporarily unavailable during this window.
Posted Nov 21, 2025 - 15:39 CAT
This scheduled maintenance affected: Trading Pairs (Cryptocurrencies, Stablecoins, Forex) and Products (RfQ).