Delays for ZAR Withdraws via Bank Wire

Incident Report for OVEX

Resolved

The issue is fully resolved and all ZAR withdrawals are operational. Thank you for your patience.
Posted Apr 30, 2026 - 10:00 CAT

Monitoring

The issue has been fixed, we are monitoring stability of outgoing withdrawals. Any delayed ZAR withdrawals are expected to be processed tomorrow morning.
Posted Apr 29, 2026 - 19:51 CAT

Update

No resolution at this time, team is still addressing the issue. We apologise for any inconvenience
Posted Apr 29, 2026 - 16:05 CAT

Investigating

We are currently experiencing delays processing ZAR withdrawals. Issue has been identified with our banking partner and team is actively working with them to resolve the issue.
Posted Apr 29, 2026 - 11:00 CAT
This incident affected: Withdrawals (ZAR Withdrawals).