General Platform instability

Incident Report for OVEX

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:21 CAT

Monitoring

All users should now be able to login and perform all actions that require 2FA. Our engineering team is currently monitoring.
Posted Jun 12, 2025 - 21:11 CAT

Investigating

Due to a wider issue with our hosting provider, some users may be experiencing trouble when logging in to OVEX and performing actions that require 2FA. Our engineering team is currently investigating.
Posted Jun 12, 2025 - 20:53 CAT