Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 24, 2024 - 20:00 CAT
Scheduled
We will be undergoing a scheduled maintenance over this time. Services should not be affected in this window but potential exists for a degradation. Engineers on standby for necessary resolutions
Posted Mar 15, 2024 - 13:11 CAT
This scheduled maintenance affected: Deposits (Crypto Deposits, USD Bank Deposits, ZAR Bank Deposits, Other Fiat Deposits), Withdrawals (Crypto Withdrawals, USD Withdrawals, ZAR Withdrawals, Other Fiat Withdrawals), Trading Pairs (Cryptocurrencies, Stablecoins, Forex), Platforms (API, Website, Helpdesk), and Products (OTC, FX Trading, On/Off Ramps, Interest Accounts).