Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 07, 2025 - 11:45 CAT
Scheduled
As part of the Ethereum Pectra upgrade, all deposits and withdrawals via ERC will be paused. Functionality expected to resume by 12:00 UTC, once the upgrade is complete and network is stable.
Posted May 07, 2025 - 11:44 CAT
This scheduled maintenance affected: Deposits (Crypto Deposits), Withdrawals (Crypto Withdrawals), and Platforms (API, Mobile App, Website).